Learning SketchUp: Overview

This tutorial will provide an overview of a few of the most useful tools that you will be using. Most
of the tools are accessed by icons on the left of the screen. Hold the cursor over a tool icon for a
few seconds and the tool name will appear.

SketchUp
SketchUp 7 Pro is installed in the computer labs. However, for our course the standard version is
absolutely sufficient. You can download it for free at hiip://sketchup.google.com/download/.

Opening SketchUp

When opening SketchUp for the first time choose the template Architectural Design - Milimeters.
Then turn on the following toolbars:

Ot ] e RENE 8T Y e
! —§ ¥ SceneTabs ¥ Large Teal Set
L Hidden Geometry (F——
’5 $ ¥ Section Planes Construction
o Section Cute Deawing
: (,(‘ o Aues o Faceltyle
¥ Guides Gougle
B[ o sl
a ' Fog Measwements
Madification
~ § Edge Shyle ’ Principsl
g Face Style Py Sections
s (F Component Edit . Shadows
o, Arimation v o Standard
2 Vv Views
g F Walkthreugh
* “‘ Dymamic Components.
/ Sandbes
?\R ¥ Large Buttons

O ® © | @ setect cbjects. shift 1o extend select, Orag mause to select muliple.

Measurements

The Line tool

In SketchUp you can draw lines by clicking, and the program will automatically align them hori-
zontally or vertically if required. To create a single line, select the Line tool by left-clicking the
mouse over its icon (figure 2). Then left-click within the drawing area where you want the line to
start, and keeping your finger on the mouse, drag the mouse in any direction on the screen. By
releasing the left mouse button the endpoint of the line is established.
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Figure 2: The SketchUp interface showing the tool icons on the left and the large white drawing area. The line
tool icon is shown in detail.

To create multiple lines, that occur continuously one after the other, simply left-click a starting
point, release the mouse button, move the mouse and left-click again. The next line will then begin
at the endpoint of the previous one. Press the ESC key to finish drawing. Join the endpoint of the
final line with the startpoint of the first line to create a polygon.

When we want to make a line a specific length, simply start drawing the line into the desired direc-
tion and type in the length required (e.g. 2000) followed by enter. You will see the length in a small
box located on the bottom right on your screen:

Length | 2000mm
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SketchUp tips

If you require any help with the
buttons press the “questionmark
button” at the bottom. It will ex-
plain the function and additional
features of each button.

@

By holding the SHIFT key while
in select mode you can toggle
selected items from selected to
unselect with successive picks.

By holding the CTRL key (STRG
key) while in select mode you
can continuously add things to
the selection group without elimi-
nating any of the selection.

Press the scroll wheel down and
drag to orbit your model. Move
the scroll wheel up and down to
zoom in or out. Press SHIFT and
the scroll wheel to move around.

You can change the units from
mm into m in Window > Model
Info > Units.
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Once you become more familiar with this tool, you will notice that inference points appear on your
screen, allowing you to locate the endpoint and midpoints of other lines, speeding up the process
of making complex shapes.

Planes
You can draw in any orientation in 3D space using the line or any other tool. When you draw
Sketchup allows you to see which direction you are moving the line or object in, using the axis
colours of red (x), green (y) and the vertical blue (z) to indicate the plane that you are working in
(figure 4).

Figure 4: The short red line is being created with the line tool. It has changed to red to show that it being aligned
to the horizontal (x) axis

For example, when you draw a line it will change to the axis colour when it is aligned to that axis.
This visual feedback allows you to know in what axis we are drawing in.

Polygons
You can draw polygons using the line tool, however, regular polygons can be drawn more quickly
using one of the polygon tools such as the rectangle tool on the left hand side of your screen.

Once the tool has been activated, left-click the mouse at a point on the screen and drag the mouse
to make the shape that you want. At this point, left-click the mouse and the rectangle shape will
be completed. The dimensions of this rectangle can also be adjusted by typing in new lengths for
the x and y axis, just as you did with the line tool. Type in the x dimension first, then a semicolon
(;), then the y dimension, then enter.

The polygon tool allows you to draw regular polygons with any number of sides. To draw an oc-
tagon (8 sides) select the polygon tool type 8 and press enter to select the number of sides and
click-and-drag to draw. After the shape of the octagon appears type in the radius and click enter
to get the shape a specific size. To draw a circle select the circle tool from the tools menu at the
top of the screen.

If drawing in shaded or shaded with textures views you will notice that a coloured surface appears
over the shape once it has been completed. This is because SketchUp automatically applies a
surface to the face of a complete object, much like a skin. This allows you to manipulate the object
in 3D at a later date.

Push/Pull Tool

The push/pull tool allows you to manipulate surfaces easily to give an object a 3D form. Left-click
on the icon to activate the tool (figure 5), and move the mouse over the surface of a completed
object, such as a rectangle. As you do this you will see that the surface of the 2D object becomes
highlighted, which tells you that the object can be exiruded. Now simply left-click over the surface
and move the mouse in order to infer the direction of the extrusion. By moving the mouse upwards
the height will become positive, whilst moving the mouse downwards will give it a negative value.
Left-click the mouse at the height you require, and if necessary change this by typing in a new
value.
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Figure 5: Orbiting around an object using the orbit tool (bottom). The push/pull tool (top) is also shown.
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If you are working in a plan view, it may be necessary to orbit around this view using the orbit tool
(figure 5), so that you can gain a clearer indication of the new form. Select the orbit tool, click on
the screen, and move the cursor whilst holding down the left mouse button. Instead you can also
orbit if you press and hold down the scroll wheel of the mouse. By reselecting the push/pull tool
each surface on the newly formed 3D shape can be moved in the same way.

Groups

As you begin to work with SketchUp you will start to build models containing multiple objects. Be-
cause of the way SketchUp works with geometry these can get very complicated, and may behave
in unforeseen ways. A way round this is to group an object as soon as you build it. If objects aren’t
grouped then when you have two or more objects touching, SketchUp will attempt to simplify the
geometry by combining the objects. Grouping helps an object keep its individuality.

To group an object, first select the object you wish to group (you can do this by clicking on one
of its faces 3 times), and then go to Edit > Make Group. You can edit the group either by going to
Edit > Group > Edit group, or by double clicking on the object.

Components

Components allow you to define, organise and place ‘symbols’ in your model that are made up
from multiple drawn objects. Components are easier to manipulate than having to select many
individual edges, surface and lines within the model and they can be aligned to any surface that
you require.

SketchUp has an small inbuilt library of components that can be inserted into your model, saving
you having to draw many everyday items yourself, such as furniture and windows. It also allows
you to search the internet SketchUp database for components if you type in what you require.
Select the object you require from the library: Window > Components. Click on the component
you wish to use in your model then click within your model to place it.

It is also possible to create your own components. Each can be saved (Make Component button
next to the Select button) and their behaviour configured. The axis plane on the component will
tell you at which point the component will be inserted into your drawing, with the component being
treated as an independent geometric group.

If your building for example has 10 identical windows, rather than individually redraw them 10
times as you would have to by hand, you simply draw it once, save it as a component and reinsert
a copy of it into your drawing. Then if you decide that you want to change the appearance of the
windows, you simply alter one of them, and the rest of them will automatically be changed with
it.

Additional components can be found on the SketchUp website [http://sketchup.google.com/
download/bonuspacks6.html] and searched directly in SketchUp (Google Search inside the Com-
ponents window).

Shadows

Shadows are configured using the shadow toolbar (figure 6). If this is not visible towards the top of
the SketchUp window select View > Toolbars > Shadows. Drag the month slider to set the time of
year and the time slider to set the time of day. Click the Display Shadows button to turn shadows
on and off. Additional settings can be customised by clicking the shadows settings button (figure

6).
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Figure 6: The shadows tool bar. The Display Shadows button is highlighted.

Note: Having the Shadows switched on will slow down your machine if you have a complicated
scene or a slower machine. If this is the case, try switching them on only when you need them.

Morphing between Scenes

It is possible to save a view of any part of your model, whether in section, as an interior or as a
complete rendered image. The choices are limitless, and allow you the freedom to animate any
transition from view to view, with SketchUp filling in the gaps in-between for you.

For example you may wish to undertake a study in the effects of shadows within and around
your building. Simply set a view of the building in the morning from one angle (with the shadows
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For the shadows to be set cor-
rectly you have to assign the
correct location. You can do this
under Window > Model Info >
LLocation or by pressing the “bulb
button” in the lower left corner.
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switched on), and save it as a view by selecting View > Animation > Add Scene. When you have
done this, alter the shadows to indicate the afternoon, and repeat the procedure to save this as a
separate page. The saved views/scenes can be made as simple or complex as you wish.

To animate between saved scenes click on the scene tabs towards the top of the screen (figure
7). Alternatively, adjust the settings of the animation by selecting View > Animation > Settings.
Here the length between each frame can be decided. Once completed select View > Animation >
Play and the image will change from one view to the next. The animation can have many scenes
included within it, and can allow a complex building to be described effectively as it moves from
frame to frame. Finer adjustment on each scene can be achieved by right-clicking the scene tab
and choosing the Scene Manger.
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Figure 7: Scene tabs showing 2 scenes.

Saving your ‘tour’ as an animation

SketchUp allows you to export your views as an animation in AVI format or in separate photos.
To do this set up your animation using View > Animation > Settings and select File > Export >
Animation (adjust with Options).

Additional Training

After this introduction you will draw your first 3D building with SketchUp - the Villa Savoye from
Le Corbusier.

At home you can find more information on SketchUp if you take a look at the Video Tutorials avail-
able on the SketchUp web site:
http://download.sketchup.com/downloads/training/tutorials50/Sketchup%20Video%20Tutorials.
html or http://sketchup.google.com/training/videos.html

Those tutorials will give you in-depth knowledge of this very capable programme.

Go to Villa Savoye > >
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